common problem

NVIDIA Jetson AGX Xavier- JetPack4.2安装TensorFlow

2020-11-04 11:35:32 tuwei312 9

NVIDIA Jetson AGX Xavier- JetPack4.2安装TensorFlow

NVIDIA开发者论坛帖子
https://devtalk.nvidia.com/default/topic/1055816/confused-download-link-in-offical-l4t-guide/
最新官方教程
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html

  1. 确认jetson系统环境
    使用JetPack 4.2刷机,Xavier L4T 系统版本32.1,强调一下系统版本很重要,不同系统的因为内核的改动导致很多命令可能与之前不一样,请对照版本。

  2. 配置系统依赖库HDF5

    sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev zlib1g-dev zip libjpeg8-dev

  3. 安装pip3
    一定要用pip3,系统自带了python2,但是不要用pip

    sudo apt-get install python3-pip

    sudo pip3 install -U pip

  4. 安装python的一些依赖包
    这一步可能非常慢,虽然下的东西不多,我用国内的网只有5-6kb/s的速度。耐心等待


    sudo pip3 install -U numpy grpcio absl-py py-cpuinfo psutil portpicker six mock requests gast h5py astor termcolor protobuf keras-applications keras-preprocessing wrapt google-pasta

  5. 安装TensorFlow
    安装最新支持版本的TensorFlow

    sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu

    如果你有特定的TensorFlow版本需要安装,使用以下命令

    sudo pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu==$TF_VERSION+nv$NV_VERSION

    TF_VERSION
    TensorFlow的发行版本号,比如 1.12.0.
    NV_VERSION
    NVIDIA的TensorFlow容器版本,比如 19.01.
    例如安装19.01容器,1.12.0TensorFlow,命令如下

    sudo pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu==1.12.0+nv19.1

  6. 检查是否安装成功

    打开python3

    python3

    导入TensorFlow

    >>> import tensorflow

    如果安装成功,此处不报错。

    OK,TensorFlow安装成功





转载:https://blog.csdn.net/huiyuanliyan/article/details/92802922